30 функций Excel за 30 дней: Ч (N)

Вчера в марафоне 30 функций Excel за 30 дней мы идентифицировали содержимое ячейки при помощи функции TYPE (ТИП) и пользовались этим, чтобы проверить, содержится ли в ячейке число, перед выполнением умножения.

В 22-й день нашего марафона мы займемся изучением функции N (Ч). Она очень похожа на функцию T (Т), которую мы уже изучали ранее, но работает не с текстовыми значениями, а с числовыми.

Итак, давайте внимательно посмотрим информацию и примеры по функции N (Ч). Если у Вас есть дополнительная информация или свои примеры, пожалуйста, делитесь ими в комментариях.

Функция 22: N (Ч)

Функция N (Ч) возвращает значение, преобразованное в число.

Функция Ч в Excel

Как можно использовать функцию N (Ч)?

Функция N (Ч) используется не слишком широко и, как правило, может быть заменена другими функциями или операторами. Вы можете:

  • Возвратить число, основываясь на значении ячейки.
  • Использовать альтернативы функции N (Ч).
  • Добавить скрытый комментарий к ячейке.

Синтаксис N (Ч)

Функция N (Ч) имеет следующий синтаксис:

N(value)
Ч(значение)

  • value (значение) – может быть текстом, числом или любым другим значением.

Ловушки N (Ч)

Если значением является ошибка, то функция N (Ч) возвратит точно такую же ошибку вместо числа. Чтобы справиться с ошибками, используйте IFERROR (ЕСЛИОШИБКА) или ISNUMBER (ЕЧИСЛО).

Пример 1: Возвращаем число, основываясь на значении ячейки

При помощи функции N (Ч) Вы можете возвратить число, основываясь на значении ячейки. Если в ячейке находится число, то функция возвратит это же число.

=N(C3)
=Ч(C3)

Функция Ч в Excel

Следующая таблица показывает, какие результаты возвратит функция N (Ч) для возможных значений:

Функция Ч в Excel

Пример 2: Альтернативы для функции N (Ч)

Вместо функции N (Ч) Вы можете использовать функцию ISNUMBER (ЕЧИСЛО), чтобы проверить наличие числа в ячейке.

=ISNUMBER(C3)
=ЕЧИСЛО(C3)

Функция Ч в Excel

Или использовать два знака минус (двойное отрицание), чтобы логические значения TRUE/FALSE (ИСТИНА/ЛОЖЬ) или числа в текстовом формате преобразовать в числовые значения.

=IFERROR(--C3,"")
=ЕСЛИОШИБКА(--C3;"")

Функция Ч в Excel

Пример 3: Добавляем скрытый комментарий к ячейке

Если необходимо добавить к ячейке скрытый комментарий, то для этого можно использовать функцию N (Ч). Поскольку результатом функции N (Ч) для текста будет ноль, то прибавление такой записи не изменит итоговый результат ячейки.

Такой комментарий будет виден только в строке формул, когда выбрана содержащая его ячейка.

=SUM(B3:C3)+N("Store01 closed in June")
=СУММ(B3:C3)+Ч("Store01 closed in June")

Функция Ч в Excel

02.03.2015 13:54
1899

Комментарии

Нет комментариев. Ваш будет первым!