30 функций Excel за 30 дней: НАЙТИ (FIND)

Вчера в марафоне 30 функций Excel за 30 дней у нас был разгрузочный день с функцией N (Ч), где мы выяснили, что она может возвратить число, основываясь на типе содержимого ячейки.

23-й день марафона мы посвятим изучению функции FIND (НАЙТИ). Она очень похожа на функцию SEARCH (ПОИСК), с которой мы встречались ранее, но функция FIND (НАЙТИ) чувствительна к регистру.

Итак, давайте посмотрим сведения и примеры по функции FIND (НАЙТИ). Если у Вас есть дополнительная информация или примеры, пожалуйста, делитесь ими в комментариях.

Функция 23: FIND (НАЙТИ)

Функция FIND (НАЙТИ) находит текстовую строку внутри другой текстовой строки с учётом регистра.

Функция НАЙТИ в Excel

Как можно использовать функцию FIND (НАЙТИ)?

Функция FIND (НАЙТИ) может найти текст внутри текстовой строки, учитывая регистр символов. Например:

  • Найти начальную позицию текста в текстовой строке.
  • Найти точные данные на листе.
  • Найти название улицы в адресе.

Синтаксис FIND (НАЙТИ)

Функция FIND (НАЙТИ) имеет вот такой синтаксис:

FIND(find_text,within_text,[start_num])
НАЙТИ(искомый_текст;просматриваемый_текст;[нач_позиция])

  • find_text (искомый_текст) – текст, который Вы ищете.
  • within_text (просматриваемый_текст) – текстовая строка, внутри которой происходит поиск.
  • start_num (нач_позиция) – если не указан, то поиск начнётся с первого символа.

Ловушки FIND (НАЙТИ)

  • Функция FIND (НАЙТИ) возвратит позицию первой совпадающей строки с учётом регистра. Для того, чтобы произвести поиск без учёта регистра, используйте функцию SEARCH (ПОИСК), которую мы уже рассматривали ранее в рамках марафона 30 функций Excel за 30 дней.
  • В аргументе find_text (искомый_текст) функции FIND (НАЙТИ) нельзя использовать символы подстановки. Если Вы все-таки хотите их использовать, то применяйте функцию SEARCH (ПОИСК).

Пример 1: Находим текст в текстовой строке

Чтобы найти нужный текст в текстовой строке, используйте функцию FIND (НАЙТИ). Она чувствительна к регистру, поэтому на рисунке ниже первые два символа "i" игнорируются.

=FIND(B5,B2)
=НАЙТИ(B5;B2)

Чтобы обработать ошибки, возникающие, если текст не найден, поместите FIND (НАЙТИ) в функцию IFERROR (ЕСЛИОШИБКА). Если у Вас Excel 2003 или более ранняя версия, вместо IFERROR (ЕСЛИОШИБКА) используйте функцию IF (ЕСЛИ) вместе с ISERROR (ЕОШИБКА).

=IFERROR(FIND(B5,B2),"Not Found")
=ЕСЛИОШИБКА(НАЙТИ(B5;B2);"Not Found")

Функция НАЙТИ в Excel

Пример 2: Находим точные значения на листе

Пользуясь тем, что функция FIND (НАЙТИ) чувствительна к регистру, Вы можете использовать её для точного поиска строки текста внутри другой строки. В этом примере в столбце E записаны значения допустимых кодов (Valid Codes). При помощи функции FIND (НАЙТИ) мы можем определить содержит ли значение в ячейке B2 хотя бы один из допустимых кодов.

Эта формула должна быть введена, как формула массива, нажатием Ctrl+Shift+Enter.

=IF(OR(ISNUMBER(FIND($E$2:$E$4,B2))),"Yes","No")
=ЕСЛИ(ЕЧИСЛО(НАЙТИ($E$2:$E$4;B2)));"Yes";"No")

Функция НАЙТИ в Excel

Пример 3: Находим название улицы в адресе

В следующем примере большинство адресов в столбце B начинается с номера. При помощи формулы в столбце C мы проверяем, является ли первый символ цифрой. Если это цифра, то функция FIND (НАЙТИ) находит первый символ пробела, а функция MID (ПСТР) возвращает весь оставшийся текст, начиная со следующего символа.

=IF(ISNUMBER(--LEFT(B2,1)),MID(B2,FIND(" ",B2)+1,LEN(B2)),B2)
=ЕСЛИ(ЕЧИСЛО(--ЛЕВСИМВ(B2;1));ПСТР(B2;НАЙТИ(" ";B2)+1;ДЛСТР(B2));B2)

Функция НАЙТИ в Excel

03.03.2015 00:10
4379

Комментарии

Нет комментариев. Ваш будет первым!