30 функций Excel за 30 дней: СМЕЩ (OFFSET)

Вчера в марафоне 30 функций Excel за 30 дней мы заменяли текстовые строки с помощью функции REPLACE (ЗАМЕНИТЬ) и выяснили, что вставлять символы она тоже умеет.

В 26-й день марафона мы будем изучать функцию OFFSET (СМЕЩ). Она возвращает ссылку заданного размера, отстоящую от стартовой ссылки на указанное количество строк и столбцов.

Итак, давайте изучим информацию и примеры применения функции OFFSET (СМЕЩ), а если у Вас есть дополнительные сведения и свои примеры, пожалуйста, делитесь ими в комментариях.

Функция 26: OFFSET (СМЕЩ)

Функция OFFSET (СМЕЩ) возвращает ссылку, смещённую от заданной ссылки на определенное количество строк и столбцов.

Функция СМЕЩ в Excel

Как можно использовать функцию OFFSET (СМЕЩ)?

Функция OFFSET (СМЕЩ) может возвратить ссылку на диапазон, а также работать в сочетании с другими функциями. Используйте её для того, чтобы:

  • Находить суммы продаж для выбранного месяца.
  • Суммировать данные о продажах за выбранные месяцы.
  • Создавать динамические диапазоны на основе подсчета.
  • Суммировать продажи за последние n месяцев.

Синтаксис OFFSET (СМЕЩ)

Функция OFFSET (СМЕЩ) имеет вот такой синтаксис:

OFFSET(reference,rows,cols,[height],[width])
СМЕЩ(ссылка;смещ_по_строкам;смещ_по_столбцам;[высота];[ширина])

  • reference (ссылка) – ячейка или диапазон смежных ячеек.
  • rows (смещ_по_строкам) – может быть положительным (вниз от начальной ссылки) или отрицательным (вверх от начальной ссылки).
  • cols (смещ_по_столбцам) - может быть положительным (вправо от начальной ссылки) или отрицательным (влево от начальной ссылки).
  • height (высота) – количество строк в возвращаемой ссылке, должен быть положительным.
  • width (ширина) – количество столбцов в возвращаемой ссылке, должен быть положительным.
  • Если аргументы height (высота) или width (ширина) не указаны, используются размеры исходной ссылки.

Ловушки OFFSET (СМЕЩ)

Функция OFFSET (СМЕЩ) пересчитывается каждый раз при любом изменении значений на листе Excel. Используя эту функцию во многих формулах, можно сильно замедлить работу. Вместо OFFSET (СМЕЩ) Вы можете использовать функцию INDEX (ИНДЕКС), чтобы возвратить ссылку. INDEX (ИНДЕКС) пересчитывает результат только при изменении своих аргументов.

Пример 1: Находим сумму продаж для выбранного месяца

При помощи функции OFFSET (СМЕЩ) Вы можете возвращать ссылку на диапазон, отталкиваясь от стартовой ссылки. В этом примере мы хотим получить сумму продаж в ячейке G2.

  • Стартовая ссылка – это ячейка C1.
  • Количество строк для сдвига вводится в ячейке F2.
  • Суммы продаж находятся в столбце C, поэтому сдвиг по столбцам равен нулю.
  • Аргумент height (высота) равен 1 строке.
  • Аргумент width (ширина) равен 1 столбцу.

=OFFSET(C1,F2,0,1,1)
=СМЕЩ(C1;F2;0;1;1)

В ячейке H2 находится формула, очень похожая на предыдущую, которая возвращает имя месяца. Единственное отличие – это сдвиг по столбцам: 1 вместо 0.

=OFFSET(C1,F2,1,1,1)
=СМЕЩ(C1;F2;1;1;1)

Замечание: В данном примере аргументы height (высота) и width (ширина) можно не указывать, поскольку нам нужна ссылка того же размера, что и стартовая.

Функция СМЕЩ в Excel

Пример 2: Суммируем продажи за выбранные месяцы

В этом примере функция OFFSET (СМЕЩ) возвращает ссылку на данные о продажах за выбранный месяц, а функция SUM (СУММ) подсчитывает сумму для этого диапазона. В ячейке B10 указан номер выбранного месяца 3, следовательно, результатом будет сумма продаж в марте (Mar).

  • Начальная ссылка A3:A6.
  • Сдвиг по строкам равен нулю (если ноль вообще не указать, результат будет тот же).
  • Сдвиг по столбцам соответствует значению ячейки B10.
  • Высота и ширина не указаны, поскольку итоговый диапазон должен быть того же размера, что и начальный.

=SUM(OFFSET(A3:A6,0,B10))
=СУММ(СМЕЩ(A3:A6;0;B10))

Функция СМЕЩ в Excel

Пример 3: Создаем динамический диапазон, основанный на подсчете

Вы можете использовать функцию OFFSET (СМЕЩ), чтобы создать динамический диапазон. В этом примере мы создали именованный диапазон MonthList с такой формулой:

=OFFSET('Ex03'!$C$1,0,0,COUNTA('Ex03'!$C:$C),1)
=СМЕЩ('Ex03'!$C$1;0;0;СЧЁТЗ('Ex03'!$C:$C);1)

Функция СМЕЩ в Excel

Если к списку в столбце C добавить ещё один месяц, он автоматически появится в выпадающем списке в ячейке F2, который использует имя MonthList, как источник данных.

Функция СМЕЩ в Excel

Пример 4: Суммируем продажи за последние n месяцев

В этом заключительном примере OFFSET (СМЕЩ) работает вместе с SUM (СУММ) и COUNT (СЧЁТ), чтобы показать сумму за последние n месяцев. Как только добавляются новые значения, результат формулы будет автоматически скорректирован, чтобы включить величину продаж за последний месяц. В ячейке E2 количество месяцев равно 2, поэтому складываться будут суммы за август (Aug-10) и сентябрь (Sep-10).

  • Начальная ссылка – ячейка C2.
  • Количество строк для сдвига рассчитывается так:
    • подсчитываем количество чисел в столбце C,
    • вычитаем из результата количество месяцев, указанное в ячейке E3,
    • и прибавляем 1.
  • Продажи находятся в столбце C, поэтому сдвиг по столбцам равен нулю.
  • Высота введена в ячейке E3.
  • Ширина равна 1 столбцу.

=SUM(OFFSET(C2,COUNT(C:C)-E3+1,0,E3,1))
=СУММ(СМЕЩ(C2;СЧЁТ(C:C)-E3+1;0;E3;1))

Функция СМЕЩ в Excel

04.03.2015 12:56
6082

2 комментария

04.02.2016 16:41
Спасибо Большое за полезную статью! формула помогает мне расчетах, информацию о ней нашла только у вас)
На здоровье!