30 функций Excel за 30 дней: ТИП.ОШИБКИ (ERROR.TYPE)

Вчера в марафоне 30 функций Excel за 30 дней мы искали значения с помощью функции LOOKUP (ПРОСМОТР). Сегодня мы вновь воспользуемся этой функцией для работы над ошибками.

17-й день марафона мы посвятим исследованиям функции ERROR.TYPE (ТИП.ОШИБКИ). Она способна распознавать типы ошибок, а Вы, в свою очередь, можете использовать эту информацию, чтобы устранить их.

Итак, рассмотрим информацию и примеры использования функции ERROR.TYPE (ТИП.ОШИБКИ) в Excel. Если у Вас есть дополнительная информация или примеры, пожалуйста, делитесь ими в комментариях.

Функция 17: ERROR.TYPE (ТИП.ОШИБКИ)

Функция ERROR.TYPE (ТИП.ОШИБКИ) определяет тип ошибки по номеру или возвращает #N/A (#Н/Д), если ошибка не найдена.

Функция ТИП.ОШИБКИ в Excel

Как можно использовать функцию ERROR.TYPE (ТИП.ОШИБКИ)?

При помощи ERROR.TYPE (ТИП.ОШИБКИ) Вы можете:

  • идентифицировать тип ошибки.
  • помочь пользователям исправить возникающие ошибки.

Синтаксис ERROR.TYPE (ТИП.ОШИБКИ)

Функция ERROR.TYPE (ТИП.ОШИБКИ) имеет вот такой синтаксис:

ERROR.TYPE(error_val)
ТИП.ОШИБКИ(значение_ошибки)

  • error_val (значение_ошибки) – та самая ошибка, которую надо идентифицировать.
  • коды, которые возвращает функция ERROR.TYPE (ТИП.ОШИБКИ):
    • 1 … #NULL! (#ПУСТО!)
    • 2 … #DIV/0! (#ДЕЛ/0!)
    • 3 … #VALUE! (#ЗНАЧ!)
    • 4 … #REF! (#ССЫЛ!)
    • 5 … #NAME? (#ИМЯ?)
    • 6 … #NUM! (#ЧИСЛО!)
    • 7 … #N/A (#Н/Д)
    • #N/A (#Н/Д) … любое другое значение

Ловушки ERROR.TYPE (ТИП.ОШИБКИ)

Если значение аргумента error_val (значение_ошибки) не является ошибкой, результатом функции ERROR.TYPE (ТИП.ОШИБКИ) будет сообщение об ошибке #N/A (#Н/Д). Вы сможете избежать этого, если воспользуетесь функцией ISERROR (ЕОШИБКА), чтобы проверить наличие ошибки, как это показано в примере 2.

Пример 1: Определяем тип ошибки

При помощи функции ERROR.TYPE (ТИП.ОШИБКИ) Вы можете проверить ячейку, чтобы определить, какая в ней содержится ошибка. Если в ячейке нет ошибки, то вместо числового кода ошибки будет возвращено значение #N/A (#Н/Д).

=ERROR.TYPE(B3)
=ТИП.ОШИБКИ(B3)

Функция ТИП.ОШИБКИ в Excel

В этом примере ячейка B3 содержит #VALUE! (#ЗНАЧ!), поэтому тип ошибки равен 3.

Функция ТИП.ОШИБКИ в Excel

Пример 2: Помогаем пользователям разобраться с ошибками

Сочетая ERROR.TYPE (ТИП.ОШИБКИ) с другими функциями, Вы можете помочь пользователям исправить ошибки, появляющиеся в ячейке. В этом примере в ячейках B3 и C3 должны быть введены числа. Если введён текст, результатом в D3 будет сообщение об ошибке #VALUE! (#ЗНАЧ!). Если в ячейке C3 введён ноль, результатом будет сообщение об ошибке #DIV/0 (#ДЕЛ/0).

В ячейке D4 функция ISERROR (ЕОШИБКА) проверяет наличие ошибки, а ERROR.TYPE (ТИП.ОШИБКИ) возвращает номер этой ошибки. Функция LOOKUP (ПРОСМОТР) находит в таблице кодов ошибок подходящее к данной ситуации сообщение с подсказкой, как исправить ошибку, и показывает его пользователю.

=IF(ISERROR(D3),LOOKUP(ERROR.TYPE(D3),$B$9:$B$15,$D$9:$D$15),"")
=ЕСЛИ(ЕОШИБКА(D3);ПРОСМОТР(ТИП.ОШИБКИ(D3);$B$9:$B$15;$D$9:$D$15);"")

Функция ТИП.ОШИБКИ в Excel

Вот таблица соответствия числовых кодов ошибки и выводимых сообщений:

Функция ТИП.ОШИБКИ в Excel

01.03.2015 03:31
1993

Комментарии

Нет комментариев. Ваш будет первым!