Наиболее часто встречающееся слово в Excel

Из этого примера вы узнаете, как найти наиболее часто встречающееся слово в Excel.

Вы можете использовать функцию MODE (МОДА), чтобы найти наиболее часто встречающееся число. Но эта функция работает только с числами:

=MODE(A1:A7)
=МОДА(A1:A7)

Самое частотное слово в Excel

Вы можете использовать функцию COUNTIF (СЧЕТЕСЛИ), чтобы подсчитать количество вхождений каждого слова. Но нам ведь нужна одна единственная формула, которая возвратит наиболее часто встречающееся слово (в нашем примере – это слово "circle").

=COUNTIF($A$1:$A$7,C2)
=СЧЁТЕСЛИ($A$1:$A$7;C2)

Самое частотное слово в Excel

Чтобы найти наиболее часто встречающееся слово, следуйте инструкции ниже:

  1. Функция MATCH (ПОИСКПОЗ) возвращает позицию значения в заданном диапазоне.

    =MATCH(A7,A1:A7,0)
    =ПОИСКПОЗ(A7;A1:A7;0)

    Самое частотное слово в Excel

    Пояснение: Cлово "circle" (А7) найдено в позиции 2 диапазона A1:A7. Ноль в третьем аргументе позволяет вернуть точное совпадение.

  2. Чтобы найти положение наиболее часто встречающихся слов, добавим функцию MODE (МОДА) и заменим A7 на A1:A7.

    =MODE(MATCH(A1:A7,A1:A7,0))
    =МОДА(ПОИСКПОЗ(A1:A7;A1:A7;0))

  3. Закончим нажатием Ctrl+Shift+Enter.

    Самое частотное слово в Excel

Примечание: Строка формул указывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

  1. Пояснение:

    • Диапазон (массив констант), созданный с помощью функции MATCH (ПОИСКПОЗ), хранится в памяти Excel, а не в ячейках листа.
    • Массив констант выглядит следующим образом: {1;2;2;2;5;5;2}. Цифры показывают, что слово "triangle" найдено в позиции 1, "circle" в позиции 2, "circle" в позиции 2 и т.д.
    • Этот массив констант используется в качестве аргумента для функции MODE (МОДА), давая результат 2 (позиция наиболее часто встречающегося слова).
  2. Используйте этот результат и функцию INDEX (ИНДЕКС), чтобы вернуть второе слово из диапазона A1:A7, как наиболее часто встречающееся.

    =INDEX(A1:A7,MODE(MATCH(A1:A7,A1:A7,0)))
    =ИНДЕКС(A1:A7;МОДА(ПОИСКПОЗ(A1:A7;A1:A7;0)))

    Самое частотное слово в Excel

07.08.2015 16:40
2963

Комментарии

Нет комментариев. Ваш будет первым!