Поиск дубликатов в Excel с помощью условного форматирования

Этот пример научит вас находить дубликаты в Excel с помощью условного форматирования. Перейдите по этой ссылке, чтобы узнать, как удалить дубликаты.

  1. Выделите диапазон A1:C10.

    Выделение дубликатов в Excel

  2. На вкладке Главная (Home) нажмите Условное форматирование > Правила выделения ячеек (Conditional Formatting > Highlight Cells Rules) и выберите Повторяющиеся значения (Duplicate Values).

    Выделение дубликатов в Excel

  3. Определите стиль форматирования и нажмите ОК.

    Выделение дубликатов в Excel

    Результат: Excel выделил повторяющиеся имена.

    Выделение дубликатов в Excel

Примечание: Если в первом выпадающем списке Вы выберите вместо Повторяющиеся (Duplicate) пункт Уникальные (Unique), то Excel выделит только уникальные имена.

Как видите, Excel выделяет дубликаты (Juliet, Delta), значения, встречающиеся трижды (Sierra), четырежды (если есть) и т.д. Следуйте инструкции ниже, чтобы выделить только те значения, которые встречающиеся трижды:

  1. Сперва удалите предыдущее правило условного форматирования.
  2. Выделите диапазон A1:C10.
  3. На вкладке Главная (Home) выберите команду Условное форматирование > Создать правило (Conditional Formatting > New Rule).

    Выделение дубликатов в Excel

  4. Нажмите на Использовать формулу для определения форматируемых ячеек (Use a formula to determine which cells to format).
  5. Введите следующую формулу:

    =COUNTIF($A$1:$C$10,A1)=3
    =СЧЕТЕСЛИ($A$1:$C$10;A1)=3

  6. Выберите стиль форматирования и нажмите ОК.

    Выделение дубликатов в Excel

    Результат: Excel выделил значения, встречающиеся трижды.

    Выделение дубликатов в Excel

    Пояснение:

    • Выражение СЧЕТЕСЛИ($A$1:$C$10;A1) подсчитывает количество значений в диапазоне A1:C10, которые равны значению в ячейке A1.
    • Если СЧЕТЕСЛИ($A$1:$C$10;A1)=3, Excel форматирует ячейку.
    • Поскольку прежде, чем нажать кнопку Условное форматирование (Conditional Formatting), мы выбрали диапазон A1:C10, Excel автоматически скопирует формулы в остальные ячейки. Таким образом, ячейка A2 содержит формулу:

      =СЧЕТЕСЛИ($A$1:$C$10;A2)=3,

      ячейка A3:

      =СЧЕТЕСЛИ($A$1:$C$10;A3)=3 и т.д.

    • Обратите внимание, что мы создали абсолютную ссылку$A$1:$C$10.

Примечание: Вы можете использовать любую формулу, которая вам нравится. Например, чтобы выделить значения, встречающиеся более 3-х раз, используйте эту формулу:

=COUNTIF($A$1:$C$10,A1)>3
=СЧЕТЕСЛИ($A$1:$C$10;A1)>3

03.10.2015 10:30
1387

Комментарии

Нет комментариев. Ваш будет первым!