Поиск в двух столбцах в Excel

Из этого примера вы узнаете, как выполнять поиск в двух столбцах Excel. Посмотрите на пример ниже. Требуется найти зарплату сотрудника по имени James Clark.

  1. Чтобы присоединить строки, используйте оператор конкатенации "&".

    Поиск в двух столбцах в Excel

  2. Функция MATCH (ПОИСКПОЗ) возвращает позицию значения в указанном диапазоне. Вставьте функцию MATCH (ПОИСКПОЗ), как показано ниже, и нажмите Ctrl+Shift+Enter.

    =MATCH(F2&F3,A2:A8&B2:B8,0)
    =ПОИСКПОЗ(F2&F3;A2:A8&B2:B8;0)

    Поиск в двух столбцах в Excel

Примечание: Строка формул указывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

  1. Пояснение:

    • Диапазон (массив констант) A2:A8&B2:B8 хранится в памяти Excel, а не в ячейках листа.
    • Он выглядит следующим образом:

      {"JamesSmith"; "JamesAnderson"; "JamesClark"; "JohnLewis"; "JohnWalker"; "MarkReed"; "RichardLopez"}

    • Этот массив констант используется в качестве аргумента для функции MATCH (ПОИСКПОЗ), давая результат 3 (значение "JamesClark" третье в списке).
  2. Используйте этот результат и функцию INDEX (ИНДЕКС), чтобы вернуть нужное значение из диапазона С2:С8.

    =INDEX(C2:C8,MATCH(F2&F3,A2:A8&B2:B8,0))
    =ИНДЕКС(C2:C8;ПОИСКПОЗ(F2&F3;A2:A8&B2:B8;0))

    Поиск в двух столбцах в Excel

07.08.2015 16:37
1398

Комментарии

Нет комментариев. Ваш будет первым!