Предотвращение дублирования записей в Excel

Этот пример объяснит вам, как при помощи проверки данных не допустить ввода одинаковых значений пользователями.

  1. Выберите диапазон A2:A20.

    Предотвращение дублирования в Excel

  2. На вкладке Data (Данные) нажмите кнопку Data Validation (Проверка данных).

    Предотвращение дублирования в Excel

  3. Выберите Custom (Другой) из выпадающего списка Allow (Тип данных).
  4. Введите формулу, показанную ниже, в поле Formula (Формула) и нажмите ОК.

    =COUNTIF($A$2:$A$20,A2)=1
    =СЧЕТЕСЛИ($A$2:$A$20;A2)=1

    Предотвращение дублирования в Excel

    Пояснение: Функция COUNTIF (СЧЕТЕСЛИ) принимает два аргумента и подсчитывает количество значений в диапазоне A2:A20, равных значению в ячейке A2. Поскольку повторяющиеся данные нам не нужны, то такое значение может встретиться только один раз (=1). Прежде чем открыть окно проверки данных, мы выделили диапазон A2:A20, поэтому Excel автоматически скопировал формулу в остальные ячейки этого диапазона. Обратите внимание, что мы создали абсолютную ссылку на диапазон.

  5. Выделите ячейку A3 и нажмите кнопку Data Validation (Проверка данных).

    Предотвращение дублирования в Excel

    Как видно на рисунке, эта функция подсчитывает количество значений в диапазоне A2:A20, равных значению в ячейке A3. Опять же, это значение может быть обнаружено лишь однажды, поскольку мы хотим избежать дублирования данных.

  6. Введите повторяющееся значение.

Результат: Excel выдаёт сообщение об ошибке, так как вы уже вводили это число.

Предотвращение дублирования в Excel

Примечание: Чтобы указать подсказку при вводе или текст для оповещения об ошибке, перейдите на вкладку Input Message (Сообщение для ввода) или Error Allert (Сообщение об ошибке).

15.06.2015 13:23
1399

Комментарии

Нет комментариев. Ваш будет первым!