Суммирование диапазона с ошибками в Excel

Из этого примера вы узнаете, как создать формулу массива, которая суммирует диапазон с ошибками.

  1. Для проверки ошибок используем функции IF (ЕСЛИ) и ISERROR (ЕОШИБКА).

    =IF(ISEERROR(A1),0,A1)
    =ЕСЛИ(ЕОШИБКА(A1);0;A1)

    Суммирование диапазона с ошибками в Excel

    Пояснение: Функция IF (ЕСЛИ) возвращает 0, если найдена ошибка. Если нет – значение ячейки.

  2. Чтобы суммировать диапазон с ошибками, добавим функцию SUM (СУММ) и заменим А1 на A1:A7.

    =SUM(IF(ISERROR(A1:A7),0,A1:A7))
    =СУММ(ЕСЛИ(ЕОШИБКА(A1:A7);0;A1:A7))

    Суммирование диапазона с ошибками в Excel

  3. Закончим нажатием Ctrl+Shift+Enter.

    =SUM(IF(ISERROR(A1:A7),0,A1:A7))
    =СУММ(ЕСЛИ(ЕОШИБКА(A1:A7);0;A1:A7))

    Суммирование диапазона с ошибками в Excel

Примечание: Строка формул указывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

Пояснение:

  • Диапазон (массив констант), созданный с помощью функции IF (ЕСЛИ), хранится в памяти Excel, а не в ячейках листа.
  • Массив констант выглядит следующим образом: {0;5;4;0;0;1;3}.
  • Этот массив констант используется в качестве аргумента для функции SUM (СУММ), давая результат 13.
07.08.2015 16:32
1381

Комментарии

Нет комментариев. Ваш будет первым!