Суммирование каждой n-ой строки в Excel

Этот пример объяснит, как создать формулу массива, которая суммирует каждую n-ую строку в Excel. Мы покажем формулу на примере n = 3, но вы можете сделать это для любого другого числа.

  1. Функция ROW (СТРОКА) возвращает номер строки, в которой находится ячейка.

    =ROW(A1)
    =СТРОКА(A1)

    Суммирование n-ой строки в Excel

  2. Функция MOD (ОСТАТ) выводит остаток от деления. Например:

    • для первой строки результат равен 1, а 1 делится на 3 (0 раз) с остатком 1.
    • для третьей строки результат равен 3, а 3 делится на 3 (ровно 1 раз) с остатком 0.
    • В результате формула возвращает 0 для каждой третьей строки.

    =MOD(ROW(A1),3)
    =ОСТАТ(СТРОКА(A1);3)

    Суммирование n-ой строки в Excel

Примечание: Измените 3 на 4, чтобы суммировать каждую четвёртую строку, на 5 – каждую пятую и т.д.

  1. Слегка измените формулу, как показано ниже:

    =MOD(ROW(A1),3)=0
    =ОСТАТ(СТРОКА(A1);3)=0

    Суммирование n-ой строки в Excel

  2. Чтобы получить сумму произведения этих двух диапазонов (ЛОЖЬ = 0, ИСТИНА = 1), используйте функцию SUM (СУММ) и закончите ввод формулы сочетанием клавиш Ctrl+Shift+Enter.

    =SUM(A1:A9*(MOD(ROW(A1:A9),3)=0))
    =СУММ(A1:A9*(ОСТАТ(СТРОКА(A1:A9);3)=0))

    Суммирование n-ой строки в Excel

Примечание: Строка формул показывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

Пояснение:

  • Произведение этих двух диапазонов (массив констант) хранится в памяти Excel, а не в ячейках листа.
  • Массив констант выглядит следующим образом: {0;0;5;0;0;66;0;0;21}.
  • Этот массив констант используется в качестве аргумента для функции SUM (СУММ), давая результат 92.
05.08.2015 09:17
1401

Комментарии

Нет комментариев. Ваш будет первым!