Автоматизированный счет-фактура в Excel

В этой статье говорится о том, как автоматизировать создание счет-фактуры в Excel.

Вот так выглядит счет-фактура. Если вы выберите порядковый номер клиента из раскрывающегося списка в ячейке E6, Excel автоматически заполнит таблицу информацией о клиенте. Если выберите порядковый номер продукта в одном из выпадающих списков диапазона А13:A31, Excel автоматически заполнит информацию о продукте.

Автоматизированный счет-фактура в Excel

Далее мы расскажем, как автоматизировали ввод информации о продукте. Те же приемы использовались для ввода информации о клиенте.

  1. Введите информацию о продукте на листе Products.

    Автоматизированный счет-фактура в Excel

  2. Выделите диапазон ячеек A13:A31 на листе Invoice.
  3. На вкладке Data (Данные) кликните по команде Data Validation (Проверка данных).

    Автоматизированный счет-фактура в Excel

  4. Выберите List (Список) из раскрывающегося списка Allow (Тип данных).
  5. Поместите курсор в строку Source (Источник) и выберите диапазон A2:A5 на листе Products.
  6. Вручную измените 5 на 1048576 (или любое другое крупное число), чтобы добавить больше ячеек. Теперь вы сможете вписать столько новых продуктов, сколько нужно.

    Автоматизированный счет-фактура в Excel

  7. Нажмите OK.
  8. Выделите ячейку B13 и введите формулу, показанную ниже:

    =IF(ISBLANK(A13),"",VLOOKUP($A13,Products!$A:$C,2,FALSE))
    =ЕСЛИ(ЕПУСТО(A13);"";ВПР($A13;Products!$A:$C;2;ЛОЖЬ))

    Автоматизированный счет-фактура в Excel

Пояснение: Если ячейка А13 пуста, формула возвращает пустую строку. Если нет, функция VLOOKUP (ВПР) ищет порядковый номер продукта (1001) в крайнем левом столбце диапазона $A:$C листа Products и возвращает значение во второй столбец той же строки.

  1. Выберите ячейку С13 и введите формулу, показанную ниже:

    =IF(ISBLANK(A13),"",VLOOKUP($A13,Products!$A:$C,3,FALSE))
    =ЕСЛИ(ЕПУСТО(A13);"";ВПР($A13;Products!$A:$C;3;ЛОЖЬ))

    Автоматизированный счет-фактура в Excel

Пояснение: Эта формула почти такая же, как и предыдущая. Но на этот раз она возвращает значение в третий столбец той же строки.

  1. Выделите ячейку Е13 и введите формулу, показанную ниже:

    =IF(ISBLANK(A13),"",C13*D13)
    =ЕСЛИ(ЕПУСТО(A13);"";C13*D13)

    Автоматизированный счет-фактура в Excel

Пояснение: Если ячейка А13 пуста, формула возвращает пустую строку. Если нет, – произведение цены и количества.

  1. Чтобы скопировать формулы в другие ячейки, выделите диапазон В13:Е13 и протяните его вниз до строки 31. Используйте Format Painter (Формат по образцу), чтобы восстановить форматирование.
15.06.2015 00:12
1373

Комментарии

Нет комментариев. Ваш будет первым!