Чеклист в Excel

Этот пример научит вас создавать чеклисты в Excel. Сперва перейдите на вкладку Разработчик (Developer), чтобы иметь возможность создать чеклист.

Чеклист в Excel

  1. Нажмите кнопку Вставить (Insert). Затем из раздела Элементы управления формы (Form Controls section) выберите Флажок (Check Box).
  2. Поместите флажок в ячейку B2.

    Чеклист в Excel

  3. Чтобы удалить надпись "Флажок 1", кликните правой кнопкой мыши по флажку, затем по тексту и удалите его.
  4. Выделите ячейку В2.
  5. Зажмите её нижний правый угол и протяните его вниз до ячейки B11.

    Чеклист в Excel

  6. Кликните правой кнопкой мыши по первому флажку и нажмите Формат объекта (Format Control).

    Чеклист в Excel

  7. Установите связь с соседней ячейкой (C2).

    Чеклист в Excel

  8. Повторите шаг 7 для остальных чекбоксов.
  9. Чтобы подсчитать количество элементов, вставьте следующую формулу в ячейку B14:

    =СЧЕТЕСЛИ(C2:C11;ИСТИНА)
    =COUNTIF(C2:C11,TRUE)

    Чеклист в Excel

  10. Скройте столбец С.
  11. Вставьте представленную ниже формулу в ячейку B16:

    =ЕСЛИ(B14=B13;"Да";"НЕТ")
    =IF(B14=B13,"YES";"NO")

Результат:

Чеклист в Excel

Примечание: Мы создали правила условного форматирования, чтобы цвет фона ячейки B16 изменялся в зависимости от её значения.

04.10.2015 17:50
3958

Комментарии

Нет комментариев. Ваш будет первым!