Двумерный поиск в Excel

В этом примере мы объясним вам, как искать значения в двумерном диапазоне. Мы будем использовать функции MATCH (ПОИСКПОЗ) и INDEX (ИНДЕКС).

На рисунке ниже вы видите график продаж различных видов мороженого в каждом месяце.

  1. Чтобы найти номер строки Feb (февраль), используйте функцию MATCH (ПОИСКПОЗ):

    =MATCH(G2,A2:A13,0)
    =ПОИСКПОЗ(G2;A2:A13;0)

    Двумерный поиск в Excel

  2. Чтобы найти номер столбца Chocolate (шоколадное), снова воспользуйтесь функцией MATCH (ПОИСКПОЗ):

    =MATCH(G3,B1:D1,0)
    =ПОИСКПОЗ(G3;B1:D1;0)

    Двумерный поиск в Excel

  3. Чтобы найти продажи шоколадного мороженого в феврале, используйте функцию INDEX (ИНДЕКС):

    =INDEX(B2:D13,H2,H3)
    =ИНДЕКС(B2:D13;H2;H3)

    Двумерный поиск в Excel

  4. А теперь совместите все:

    =INDEX(B2:D13,MATCH(G2,A2:A13,0),MATCH(G3,B1:D1,0))
    =ИНДЕКС(B2:D13;ПОИСКПОЗ(G2;A2:A13;0);ПОИСКПОЗ(G3;B1:D1;0))

    Двумерный поиск в Excel

29.07.2015 12:56
1375

Комментарии

Нет комментариев. Ваш будет первым!