Формулы и функции в Excel

Формула представляет собой выражение, которое вычисляет значение ячейки. Функции – это предопределенные формулы и они уже встроены в Excel.

Например, на рисунке ниже ячейка А3 содержит формулу, которая складывает значения ячеек А2 и A1.

Формулы и функции в Excel

Ещё один пример. Ячейка A3 содержит функцию SUM (СУММ), которая вычисляет сумму диапазона A1:A2.

=SUM(A1:A2)
=СУММ(A1:A2)

Формулы и функции в Excel

Ввод формулы

Чтобы ввести формулу, следуйте инструкции ниже:

  1. Выделите ячейку.

  2. Чтобы Excel знал, что вы хотите ввести формулу, используйте знак равенства (=).

  3. К примеру, на рисунке ниже введена формула, суммирующая ячейки А1 и А2.

    Формулы и функции в Excel

Совет: Вместо того, чтобы вручную набирать А1 и А2, просто кликните по ячейкам A1 и A2.

  1. Измените значение ячейки A1 на 3.

    Формулы и функции в Excel

    Excel автоматически пересчитывает значение ячейки A3. Это одна из наиболее мощных возможностей Excel.

Редактирование формул

Когда вы выделяете ячейку, Excel показывает значение или формулу, находящиеся в ячейке, в строке формул.

Формулы и функции в Excel

  1. Чтобы отредактировать формулу, кликните по строке формул и измените формулу.

  2. Формулы и функции в Excel

  3. Нажмите Enter.

    Формулы и функции в Excel

Приоритет операций

Excel использует встроенный порядок, по которому ведутся расчеты. Если часть формулы в скобках, она будет вычислена в первую очередь. Затем выполняется умножение или деление. После этого Excel будет складывать и вычитать. Смотрите пример ниже:

Формулы и функции в Excel

Сперва Excel умножает (A1*A2), затем добавляет значение ячейки A3 к этому результату.

Другой пример:

Формулы и функции в Excel

Сначала Excel вычисляет значение в круглых скобках (A2+A3), потом умножает полученный результат на величину ячейки A1.

Копировать/вставить формулу

Когда вы копируете формулу, Excel автоматически подстраивает ссылки для каждой новой ячейки, в которую копируется формула. Чтобы понять это, выполните следующие действия:

  1. Введите формулу, показанную ниже, в ячейку A4.

    Формулы и функции в Excel

  2. Выделите ячейку А4, кликните по ней правой кнопкой мыши и выберите команду Copy (Копировать) или нажмите сочетание клавиш Ctrl+C.

    Формулы и функции в Excel

  3. Далее выделите ячейку B4, кликните по ней правой кнопкой мыши и выберите команду Insert (Вставить) в разделе Paste Options (Параметры вставки) или нажмите сочетание клавиш Ctrl+V.

    Формулы и функции в Excel

  4. Ещё вы можете скопировать формулу из ячейки A4 в B4 протягиванием. Выделите ячейку А4, зажмите её нижний правый угол и протяните до ячейки В4. Это намного проще и дает тот же результат!

    Формулы и функции в Excel

    Результат: Формула в ячейке B4 ссылается на значения в столбце B.

    Формулы и функции в Excel

Вставка функции

Все функции имеют одинаковую структуру. Например:

SUM(A1:A4)
СУММ(A1:A4)

Название этой функции - SUM (СУММ). Выражение между скобками (аргументы) означает, что мы задали диапазон A1:A4 в качестве входных данных. Эта функция складывает значения в ячейках A1, A2, A3 и A4. Запомнить, какие функции и аргументы использовать для каждой конкретной задачи не просто. К счастью, в Excel есть команда Insert Function (Вставить функцию).

Чтобы вставить функцию, сделайте следующее:

  1. Выделите ячейку.

  2. Нажмите кнопку Insert Function (Вставить функцию).

    Формулы и функции в Excel

    Появится одноименное диалоговое окно.

  3. Отыщите нужную функцию или выберите её из категории. Например, вы можете выбрать функцию COUNTIF (СЧЕТЕСЛИ) из категории Statistical (Статистические).

    Формулы и функции в Excel

  4. Нажмите ОК. Появится диалоговое окно Function Arguments (Аргументы функции).

  5. Кликните по кнопке справа от поля Range (Диапазон) и выберите диапазон A1:C2.

  6. Кликните в поле Criteria (Критерий) и введите ">5".

  7. Нажмите OK.

    Формулы и функции в Excel

    Результат: Excel подсчитывает число ячеек, значение которых больше 5.

    =COUNTIF(A1:C2;">5")
    =СЧЁТЕСЛИ(A1:C2;">5")

    Формулы и функции в Excel

Примечание: Вместо того, чтобы использовать инструмент «Вставить функцию», просто наберите =СЧЕТЕСЛИ(A1:C2,">5"). Когда напечатаете " =СЧЁТЕСЛИ( ", вместо ввода "A1:C2" вручную выделите мышью этот диапазон.

18.08.2015 22:20
2692

Комментарии

Нет комментариев. Ваш будет первым!