Функции ЧЁТН и НЕЧЁТ в Excel

На этом примере мы продемонстрируем работу функций EVEN (ЧЁТН) и ODD (НЕЧЁТ) в Excel. Также вы узнаете, как определить, является число чётным или нечётным.

ЧЁТН

  1. Округлим положительное число до ближайшего четного целого.

    =EVEN(A1)
    =ЧЁТН(A1)

    ЧЁТН и НЕЧЁТН в Excel

  2. Округлим отрицательное число до ближайшего четного целого с помощью той же формулы.

    ЧЁТН и НЕЧЁТН в Excel

НЕЧЁТ

  1. Округлим положительное число до ближайшего нечетного целого.

    =ODD(A1)
    =НЕЧЁТ(A1)

    ЧЁТН и НЕЧЁТН в Excel

  2. Округлим отрицательное число до ближайшего нечетного целого с помощью той же формулы.

    ЧЁТН и НЕЧЁТН в Excel

Чётное или нечётное?

Один из способов определить, является число четным или нечетным, – использовать функцию MOD (ОСТАТ). Функция MOD (ОСТАТ) возвращает остаток от деления.

  1. Чётные целые числа, разделенные на 2, всегда дают в остатке 0. Например, 28 делится на 2 (ровно 14 раз) и даёт остаток 0. На примере функция IF (ЕСЛИ) возвращает «Even», т.е. «Чётное».

    =IF(MOD(A2,2)=0,"Even","Odd")
    =ЕСЛИ(ОСТАТ(А2;2)=0;"Четное";"Нечетное")

    ЧЁТН и НЕЧЁТН в Excel

  2. Нечетные целые числа, разделенные на 2, всегда дают остаток 1. Например, 29 делится на 2 (14 раз) и даёт остаток 1. На примере функция IF (ЕСЛИ) возвращает «Odd», т.е. «Нечётное».

    ЧЁТН и НЕЧЁТН в Excel

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: http://www.excel-easy.com/examples/even-odd.html
Перевела: Ольга Гелих
Правила перепечатки
Еще больше уроков по Microsoft Excel

Добавить комментарий

восемнадцать − четыре =

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: