Функции Excel для работы со ссылками и массивами

В этом примере Вы узнаете всё о функциях Excel для работы со ссылками и массивами, такими как ВПР, ГПР, ПОИСКПОЗ, ИНДЕКС и ВЫБОР.

ВПР

Функция ВПР (VLOOKUP) ищет значение в крайнем левом столбце таблицы и возвращает значение ячейки, находящейся в указанном столбце той же строки.

  1. Вставляем функцию ВПР:

    =ВПР(A2;$E$4:$G$7;3;ЛОЖЬ)
    =VLOOKUP(A2,$E$4:$G$7,3,FALSE)

    Функции для работы со ссылками и массивами в Excel

    Пояснение:

    • Функция ВПР ищет значение ID (104) в крайнем левом столбце диапазона $E$4:$G$7 и возвращает значение из третьего столбца той же строки (так как третий аргумент функции имеет значение 3).
    • Четвёртый аргумент функции равен ЛОЖЬ (FALSE) – это значит, что либо будет найдено точное совпадение, либо будет показано сообщение об ошибке #Н/Д (#N/A).
  2. Потащите мышью, чтобы скопировать функцию ВПР из ячейки B2 вниз по столбцу до ячейки B11.

    Функции для работы со ссылками и массивами в Excel

    Пояснение: Когда мы копируем функцию ВПР вниз, абсолютная ссылка $E$4:$G$7 остаётся неизменной, в то время как относительная ссылка A2 изменяется на A3, A4, A5 и так далее.

ГПР

Похожим образом работает и функция ГПР (HLOOKUP):

Функции для работы со ссылками и массивами в Excel

ПОИСКПОЗ

Функция ПОИСКПОЗ (MATCH) возвращает позицию искомого значения в заданном диапазоне:

Функции для работы со ссылками и массивами в Excel

Пояснение:

  • Слово Yellow занимает третью позицию в диапазоне E4:E7.
  • Третий аргумент функции не обязателен. Если для этого аргумента ввести значение 0 (ноль), то функция возвратит позицию элемента, точно совпадающего с искомым значением (A2). Если же точное совпадение найдено не будет, то функция вернет ошибку #Н/Д (#N/A).

ИНДЕКС

Функция ИНДЕКС (INDEX) возвращает заданное значение из двухмерного или одномерного диапазона.

Функции для работы со ссылками и массивами в Excel

Пояснение: Значение 92 находится на пересечении строки 3 и столбца 2 в диапазоне E4:F7.

Функции для работы со ссылками и массивами в Excel

Пояснение: Значение 97 находится на 3 месте в диапазоне E4:E7.

ВЫБОР

Функция ВЫБОР (CHOOSE) выбирает значение из списка по заданному номеру позиции.

Функции для работы со ссылками и массивами в Excel

Пояснение: Слово Boat находится в позиции 3.

23.05.2016 14:10
4618

Комментарии

Нет комментариев. Ваш будет первым!