Функции СЧЁТ и СУММ в Excel

Самые часто используемые функции в Excel – это функции, которые подсчитывают и складывают. Подсчитывать и складывать (суммировать) можно на основе одного или нескольких критериев.

СЧЁТ

Для подсчета количества ячеек, которые содержат числа, используйте функцию СЧЁТ (COUNT).

=СЧЁТ(A1:A5)
=COUNT(A1:A5)

СЧЁТ и СУММ в Excel

СЧЕТЕСЛИ

Для подсчета ячеек по одному критерию (например, больше 9), используйте функцию СЧЕТЕСЛИ (COUNTIF).

=СЧЁТЕСЛИ(A1:A5;">9")
=COUNTIF(A1:A5,">9")

СЧЁТ и СУММ в Excel

СЧЁТЕСЛИМН

Чтобы подсчитать ячейки, основываясь на нескольких критериях (например, содержащие "green" и больше 9), применяйте функцию СЧЁТЕСЛИМН (COUNTIFS).

=СЧЁТЕСЛИМН(A1:A5;"green";B1:B5;">9")
=COUNTIFS(A1:A5,"green",B1:B5,">9")

СЧЁТ и СУММ в Excel

СУММ

Для суммирования диапазона ячеек используйте функцию СУММ (SUM).

=СУММ(A1:A5)
=SUM(A1:A5)

СЧЁТ и СУММ в Excel

СУММЕСЛИ

Чтобы суммировать значения ячеек на основе одного критерия (например, больше 9), используйте функцию СУММЕСЛИ (SUMIF). В данном случае для проверки условия и суммирования используется один столбец, поэтому в функции достаточно заполнить всего два аргумента:

=СУММЕСЛИ(B1:B5;">9")
=SUMIF(B1:B5,">9")

СЧЁТ и СУММ в Excel

Чтобы суммировать значения ячеек на основе одного критерия (например, "green"), также используйте функцию СУММЕСЛИ (SUMIF). В данном случае для проверки условия и суммирования используются разные столбцы, поэтому в функции нужно заполнить три аргумента, последний – это диапазон для суммирования.

=СУММЕСЛИ(A1:A5;"green";B1:B5)
=SUMIF(A1:A5,"green",B1:B5)

СЧЁТ и СУММ в Excel

СУММЕСЛИМН

Для суммирования значений ячеек на основе нескольких критериев (например, "blue" и "green"), используйте функцию СУММЕСЛИМН (SUMIFS). Первый аргумент – это диапазон для суммирования.

=СУММЕСЛИМН(C1:C5;A1:A5;"blue";B1:B5;"green")
=SUMIFS(C1:C5,A1:A5,"blue",B1:B5,"green")

СЧЁТ и СУММ в Excel

Примечание: Аналогичным образом можно использовать функцию СРЗНАЧЕСЛИ (AVERAGEIF) и СРЗНАЧЕСЛИМН (AVERAGEIFS), чтобы рассчитать среднее значение ячеек на основе одного или нескольких критериев.

07.09.2015 23:55
3518

Комментарии

Нет комментариев. Ваш будет первым!