Считаем будние и рабочие дни в Excel

Из этого урока вы узнаете, как получить день недели по дате в Excel и как подсчитать количество будних/рабочих дней между двумя датами.

Функция ДЕНЬНЕД

  1. Функция ДЕНЬНЕД (WEEKDAY) в Excel возвращает число от 1 (воскресенье) до 7 (суббота), представляющее номер дня недели. Судя по всему, 16 декабря 2013 в формуле ниже выпадает на понедельник.

    =WEEKDAY(A1)
    =ДЕНЬНЕД(A1)

    ДЕНЬНЕД в Excel

  2. Ещё для отображения дня недели можно использовать функцию ТЕКСТ (TEXT).

    =TEXT(A1,"dddd")
    =ТЕКСТ(A1;"дддд")

    ДЕНЬНЕД в Excel

  3. Создайте пользовательский формат даты (дддд), чтобы отобразить название дня недели.

    ДЕНЬНЕД в Excel

Функция ЧИСТРАБДНИ

  1. Функция ЧИСТРАБДНИ (NETWORKDAYS) возвращает количество будних дней (исключая выходные) между двумя датами.

    =NETWORKDAYS(A1,B1)
    =ЧИСТРАБДНИ(A1;B1)

    ДЕНЬНЕД в Excel

  2. Если вы укажете список праздников, то функция ЧИСТРАБДНИ (NETWORKDAYS) вернёт количество рабочих дней (не считая выходных и праздничных дней) между двумя датами.

    =NETWORKDAYS(A1,B1,E1:E2)
    =ЧИСТРАБДНИ(A1;B1;E1:E2)

    ДЕНЬНЕД в Excel

    Календарь ниже поможет вам лучше понять функцию ЧИСТРАБДНИ (NETWORKDAYS).

    ДЕНЬНЕД в Excel

  3. Excel хранит даты в виде чисел и подсчитывает количество дней с 0 января 1900 года. Вместо того, чтобы подставлять диапазон ячеек в формулу, подставьте константы чисел, которые представляют эти даты. Чтобы это сделать, выделите E1:E2 в формуле ниже и нажмите F9.

    =NETWORKDAYS(A1,B1,{41633;41634})
    =ЧИСТРАБДНИ(A1;B1;{41633;41634})

    ДЕНЬНЕД в Excel

Функция РАБДЕНЬ

  1. Функция РАБДЕНЬ (WORKDAY) почти противоположна функции ЧИСТРАБДНИ (NETWORKDAYS). Она возвращает дату до или после указанного количества будних дней (выходные исключены).

    =WORKDAY(A1,B1)
    =РАБДЕНЬ(A1;B1)

    ДЕНЬНЕД в Excel

Примечание: Функция РАБДЕНЬ (WORKDAY) возвращает порядковый номер даты. Примените формат даты к ячейке для её отображения.

Календарь ниже поможет вам лучше понять функцию РАБДЕНЬ (WORKDAY).

ДЕНЬНЕД в Excel

Опять же, если вы подставите список праздников, функция РАБДЕНЬ (WORKDAY) вернёт дату до или после указанного количества рабочих дней (исключая выходные и праздничные дни).

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: www.excel-easy.com/examples/weekdays.html
Перевела: Ольга Гелих
Правила перепечатки
Еще больше уроков по Microsoft Excel

26.08.2015 10:02
3772

Комментарии

Нет комментариев. Ваш будет первым!