Функция ДВССЫЛ в Excel

Функция INDIRECT (ДВССЫЛ) возвращает ссылку, заданную текстовой строкой.

  1. Например, функция INDIRECT (ДВССЫЛ) на рисунке ниже сводится к:

    =INDIRECT(B1) ► =INDIRECT("С2") ► =C2 ► 5
    =ДВССЫЛ(B1) ► =ДВССЫЛ("С2") ► =C2 ► 5

    ДВССЫЛ в Excel

    Действительно ли нам нужна для этого функция INDIRECT (ДВССЫЛ)? Да! На рисунке ниже вы можете посмотреть на результат без использования функции INDIRECT (ДВССЫЛ):

    ДВССЫЛ в Excel

  2. К примеру, формула на следующем рисунке сводится к:

    =SUM(INDIRECT("E"&A1&":E"&A2)) ► =SUM(INDIRECT("E3:E6")) ► =SUM(Е3:E6) ► 27
    =СУММ(ДВССЫЛ("E"&A1&":E"&A2)) ► =СУММ(ДВССЫЛ("E3:E6")) ► =СУММ(Е3:E6) ► 27

    ДВССЫЛ в Excel

Примечание: Оператор конкатенации (&) используется для склеивания строк. Граница на рисунке выше только для иллюстрации.

  1. Ещё один пример. Приведенная ниже формула сводится к:

    =AVERAGE(INDIRECT(B1)) ► =AVERAGE(Scores) ► 9
    =СРЗНАЧ(ДВССЫЛ(B1)) ► =СРЗНАЧ(Scores) ► 9

    ДВССЫЛ в Excel

Примечание: Диапазон с названием Scores – это диапазон C2:C4.

28.07.2015 15:42
1397

Комментарии

Нет комментариев. Ваш будет первым!