Функция ЕОШИБКА в Excel

Этот пример демонстрирует работу функции ISERROR (ЕОШИБКА) в Excel.

  1. На примере ниже видно, что Excel выдаёт ошибку #DIV/0! (#ДЕЛ/0!), когда формула пытается разделить число на ноль:

    Функция ЕОШИБКА в Excel

  2. Функция ISERROR (ЕОШИБКА) проверяет наличие ошибки и возвращает значение ИСТИНА или ЛОЖЬ.

    Попробуем использовать функции IF (ЕСЛИ) и ISERROR (ЕОШИБКА). На рисунке ниже в случаях, когда ячейка содержит ошибку, возвращается значение 5. Если ошибки нет, возвращается значение 100.

    =IF(ISERROR(A2/B2),5,100)
    =ЕСЛИ(ЕОШИБКА(A2/B2);5;100)

    Функция ЕОШИБКА в Excel

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: http://www.excel-easy.com/examples/iserror.html
Перевела: Ольга Гелих
Правила перепечатки
Еще больше уроков по Microsoft Excel

Добавить комментарий

двенадцать + 16 =

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: