Функция ЕСЛИ в Excel на простом примере

Функция ЕСЛИ одна из самых популярных и часто используемых функций Excel. Используя ее совместно с операторами сравнения и другими логическими функциями Excel, можно решать достаточно сложные задачи. В этом уроке мы попробуем разобрать ее действие на простых примерах, а также научимся использовать сразу несколько функций ЕСЛИ в одной формуле.

Коротко о синтаксисе

Функция ЕСЛИ имеет всего три аргумента:

=ЕСЛИ(заданное_условие; значение_если_ИСТИНА; значение_если_ЛОЖЬ)

Первый аргумент – это условие, благодаря которому формула может принимать решения. Условие проверяется в самую первую очередь и способно вернуть всего два значения – ИСТИНА или ЛОЖЬ. Если условие истинно, то формула вернет второй аргумент, в противном случае третий.

О том, как задавать условия в Excel, читайте статьи: Как задать простое логическое условие в Excel и Используем логические функции Excel для задания сложных условий.

Пример 1

Обратимся к примеру, приведенному на рисунках ниже. В данном примере функция ЕСЛИ в первую очередь проверят условие A1>25. Если это так, то формула возвратит текстовую строку "больше 25", в любом другом случае - "меньше или равно 25".

Функция ЕСЛИ в Excel

Функция ЕСЛИ в Excel

Пример 2

Функция ЕСЛИ является очень гибкой и ее можно применять в различных ситуациях. Рассмотрим еще один пример. В таблице ниже приведены результаты переаттестации сотрудников фирмы:

Функция ЕСЛИ в Excel

В столбец C нам необходимо выставить результат экзамена, который должен содержать всего два варианта: Сдал или Не сдал. Те, кто набрал более 45 баллов – сдали экзамен, остальные нет.

  1. Выделите ячейку, в которую необходимо ввести формулу. В нашем случае это ячейка C3.
  2. Введите в нее выражение: =ЕСЛИ(B3>45; "Сдал"; "Не сдал") и нажмите Enter.

    Функция ЕСЛИ в Excel

  3. Данная формула сравнивает значение в ячейке B3 с числом 45, если значение больше 45, то возвращает строку "Сдал", иначе "Не сдал".
  4. Скопировав формулу в остальные ячейки таблицы, можно увидеть, что 2 человека из 5 не прошли переаттестацию.

    Функция ЕСЛИ в Excel

Функция ЕСЛИ и несколько условий

Функции ЕСЛИ можно вкладывать друг в друга, если необходимо расширить варианты принятия решений в Excel. Например, для рассмотренного ранее случая переаттестации сотрудников, требуется проставить не результат, а оценку из ряда: Отлично, Хорошо и Плохо. Оценка Отлично ставится при количестве баллов более 60, оценка Хорошо при более 45 и оценка Плохо в остальных случаях.

  1. Чтобы решить эту задачу, введем в ячейку C3 следующую формулу:

    =ЕСЛИ(B3>60;"Отлично";ЕСЛИ(B2>45;"Хорошо";"Плохо")) и нажмем Enter.

    Функция ЕСЛИ в Excel

  2. Данная формула обрабатывает сразу два условия. Сначала проверяется первое условие: B3>60. Если оно истинно, то формула возвращает значение "Отлично", а остальные условия не обрабатываются. Если первое условие ложно, то функция ЕСЛИ переходит ко второму: B2>45. Если второе условие истинно, то формула возвращает значение "Хорошо", а если ложно, то "Плохо".
  3. Скопировав формулу в остальные ячейки таблицы, можно увидеть, что на отлично сдал один человек, а на оценки хорошо и плохо по два человека.

    Функция ЕСЛИ в Excel

Как видите, вместо второго и третьего аргументов функции ЕСЛИ можно подставлять новые функции ЕСЛИ, тем самым расширяя число условий, которое формула может обработать. Таким образом, Вы можете создать нужное количество вложений. Правда есть очевидный недостаток такой конструкции, после 3-5 вложений формула станет нечитаемой и громоздкой, и с ней будет невозможно работать.

В Excel существуют более благородные инструменты для обработки большого количества условий, например, функция ВПР или ПРОСМОТР.

Итак, в этом уроке мы рассмотрели логическую функцию ЕСЛИ во всей ее красе и примерах, а также разобрали простой пример с использованием сразу нескольких функций ЕСЛИ в одной формуле. Надеюсь, что эта информация была для Вас полезной. Удачи Вам и больших успехов в изучении Microsoft Excel!

23.01.2015 17:37
45322

Комментарии

Нет комментариев. Ваш будет первым!