Функция СМЕЩ в Excel

Функция OFFSET (СМЕЩ) в Excel возвращает ячейку или диапазон ячеек, который находится на заданном расстоянии от указанной ячейки или диапазона ячеек.

  1. Функция OFFSET (СМЕЩ) на рисунке ниже возвращает ячейку, которая находится на 3 строки ниже и на 2 столбца правее ячейки A2. Функция OFFSET (СМЕЩ) возвращает одну ячейку, потому что заданная высота и ширина равны 1.

    =OFFSET(A2,3,2,1,1)
    =СМЕЩ(A2;3;2;1;1)

    СМЕЩ в Excel

    Результат:

    СМЕЩ в Excel

  2. Функция OFFSET (СМЕЩ) на следующем рисунке возвращает диапазон 1х2, который находится на 5 строк ниже и на 1 столбец правее ячейки A2. Функция SUM (СУММ) вычисляет сумму значений этого диапазона.

    =SUM(OFFSET(A2,5,1,1,2))
    =СУММ(СМЕЩ(A2;5;1;1;2))

    СМЕЩ в Excel

    Результат:

    СМЕЩ в Excel

Примечание: Чтобы вернуть значения ячеек (без расчета суммы), выберите диапазон такого же размера, прежде чем вставить функцию OFFSET (СМЕЩ). Если вы хотите, чтобы формула вернула ячейку или диапазон ячеек, расположенных выше и левее точки отсчета, введите отрицательные числа в качестве второго и третьего аргументов.

28.07.2015 10:40
3169

Комментарии

Нет комментариев. Ваш будет первым!