Игра «Бросить кости» в Excel

В этом примере мы расскажем, как имитировать бросание двух костей в Excel.

Примечание: Эта инструкция не обучит вас основам форматирования. Мы предполагаем, что вы уже знаете, как изменять размер и стиль шрифта, вставлять строки и столбцы, рисовать границы, изменять цвет фона и т.д.

  1. В настоящее время каждая ячейка содержит букву "l" (нижний регистр). В шрифте Wingdings она выглядит, как точка:

    Бросаем кости в Excel

  2. Введите функцию RANDBETWEEN (СЛУЧМЕЖДУ) в ячейку C2:

    =RANDBETWEEN(1,6)
    =СЛУЧМЕЖДУ(1;6)

    Бросаем кости в Excel

  3. Введите формулу, показанную ниже, в ячейки с жёлтой заливкой.

    =IF(OR(C2=2,C2=3,C2=4,C2=5,C2=6),"l","")
    =ЕСЛИ(ИЛИ(C2=2;C2=3;C2=4;C2=5;C2=6);"l";"")

    Если выпадет 2, 3, 4, 5 или 6, то эти ячейки должны содержать точку.

    Бросаем кости в Excel

  4. Введите формулу, показанную ниже, в ячейки с красной заливкой.

    =IF(OR(C2=4,C2=5,C2=6),"l","")
    =ЕСЛИ(ИЛИ(C2=4;C2=5;C2=6);"l";"")

    Если выпадет 4, 5 или 6, эти ячейки должны содержать точку.

    Бросаем кости в Excel

  5. Введите формулу, показанную ниже, в ячейки с синей заливкой.

    =IF(C2=6,"l","")
    =ЕСЛИ(C2=6;"l";"")

    Если выпадет 6, эти ячейки должны содержать точку.

    Бросаем кости в Excel

  6. Введите формулу ниже в ячейку с серой заливкой.

    =IF(OR(C2=1,C2=3,C2=5),"l","")
    =ЕСЛИ(ИЛИ(C2=1;C2=3;C2=5);"l";"")

    Если выпадет 1, 3 или 5, эта ячейка должна содержать точку.

    Бросаем кости в Excel

  7. Скопируйте диапазон C2:E5 и вставьте его в диапазон G2:I5.
  8. Измените цвет шрифта ячеек C2 и G2 на зеленый (так, чтобы не было видно цифр).
  9. Нажмите кнопку Roll the Dice (или клавишу F9).

Результат:

Бросаем кости в Excel

20.07.2015 16:16
1399

Комментарии

Нет комментариев. Ваш будет первым!