Как посчитать накопительную сумму в Excel?

На рисунке ниже Вы можете видеть таблицу Excel, в которой представлен объем продаж по дням за январь месяц 2014 года. В ячейке B20 отображается общая сумма продаж за весь месяц, вычисленная с помощью функции СУММ. Требуется посчитать объем продаж на каждую дату января относительно начала месяца, т.е. накопительную сумму.

Накопительная сумма в Excel

При подсчете накопительной суммы в Excel, необходимо, чтобы суммирование всегда начиналось с третьей строки (ячейки B3) и заканчивалось рассматриваемой строкой. Например, ячейка C3 должна содержать следующую формулу: =СУММ(B3), а если говорить точнее, то =СУММ(B3:B3), т.е. суммирование диапазона, состоящего из одной ячейки.

Накопительная сумма в Excel

Ячейка C4 такую формулу: =СУММ(B3:B4)

Накопительная сумма в Excel

Ячейка C19 такую формулу: =СУММ(B3:B19)

Накопительная сумма в Excel

Из представленных выше формул становится очевидно, что необходимая нам формула должна использовать смешанную ссылку и выглядеть следующим образом:

Накопительная сумма в Excel

Если скопировать данную формулу во все ячейки таблицы, получим следующий результат:

Накопительная сумма в Excel

Поскольку значения в ячейках B20 и C19 совпадают, то можно быть уверенным, что накопительная сумма в Excel подсчитана верно. Как видите, все просто!

24.01.2015 15:20
7776

Комментарии

Нет комментариев. Ваш будет первым!