“Левый” поиск в Excel

Недостаток функции VLOOKUP (ВПР) в том, что она может искать значения только в крайнем левом столбце таблицы. Однако иногда нужно отыскать значения в любом столбце и вернуть соответствующее значение из столбца левее. Чтобы добиться этого, просто используйте функции INDEX (ИНДЕКС) и MATCH (ПОИСКПОЗ).

  1. Функция MATCH (ПОИСКПОЗ) возвращает позицию значения в заданном диапазоне.

    =MATCH(A2,$G$4:$G$7,0)
    =ПОИСКПОЗ(A2;$G$4:$G$7;0)

    Левый поиск в Excel

    Пояснение: Число 104 найдено в строке 4 диапазона $G$4:$G$7.

  2. Используйте полученный результат, и функция INDEX (ИНДЕКС) вернёт четвёртое значение из диапазона $E$4:$E$7.

    =INDEX($E$4:$E$7,MATCH(A2,$G$4:$G$7,0))
    =ИНДЕКС($E$4:$E$7;ПОИСКПОЗ(A2;$G$4:$G$7;0))

    Левый поиск в Excel

  3. Протяните формулу из ячейки B2 до ячейки B11.

    Левый поиск в Excel

Примечание: При протягивании формулы вниз, абсолютные ссылки ($E$4:$E$7 и $G$4:$G$7) останутся такими же, в то время как относительная ссылка (А2) изменится на A3, A4, A5 и т.д.

31.07.2015 09:01
1396

Комментарии

Нет комментариев. Ваш будет первым!