Логические функции в Excel

Узнайте, как использовать логические функции Excel, такие как ЕСЛИ (IF), И (AND) и ИЛИ (OR).

Функция ЕСЛИ

Функция ЕСЛИ (IF) проверяет выполняется ли условие и возвращает значение ИСТИНА (TRUE), если оно выполняется, либо ЛОЖЬ (FALSE), если не выполняется.

  1. Выделите ячейку C1 и введите следующую формулу:

    =ЕСЛИ(A1>10;"Correct";"Incorrect")
    =IF(A1>10,"Correct","Incorrect")

    Логические функции в Excel

  2. Функция ЕСЛИ (IF) возвращает "Correct", поскольку значение в ячейке A1 больше 10.

Функция И

Функция И (AND) возвращает значение ИСТИНА (TRUE), если все условия выполняются, и ЛОЖЬ (FALSE), если хотя бы одно из условий является ложным.

  1. Выделите ячейку D1 и введите следующую формулу:

    =ЕСЛИ(И(A1>10;B1>5);"Correct";"Incorrect")
    =IF(AND(A1>10,B1>5),"Correct","Incorrect")

    Логические функции в Excel

  2. Функция И (AND) возвращает ЛОЖЬ (FALSE), так как значение в ячейке B1 меньше 5. В результате функция ЕСЛИ (IF) возвращает "Incorrect".

Функция ИЛИ

Функция ИЛИ (OR) возвращает значение ИСТИНА (TRUE), если хотя бы одно условие выполняется, и ЛОЖЬ (FALSE), если все условия ложны.

  1. Выделите ячейку E1 и введите следующую формулу:

    =ЕСЛИ(ИЛИ(A1>10;B1>5);"Correct";"Incorrect")
    =IF(OR(A1>10,B1>5),"Correct","Incorrect")

    Логические функции в Excel

  2. Функция ИЛИ (OR) возвращает ИСТИНА (TRUE), поскольку значение в ячейке А1 больше 10. В результате функция ЕСЛИ (IF) возвращает "Correct".

Примечание: Функции И (AND) и ИЛИ (OR) способны проверить до 255 условий.

07.09.2015 23:45
2910

Комментарии

Нет комментариев. Ваш будет первым!