Ограничение бюджета в Excel

В этом примере мы расскажем о том, как использовать проверку данных, чтобы предотвратить превышение бюджетного лимита пользователями.

  1. Выделите диапазон В2:В8.

    Ограничение бюджета в Excel

Примечание: Ячейка В10 содержит функцию SUM (СУММ), которая вычисляет сумму ячеек диапазона B2:B8.

  1. На вкладке Data (Данные) нажмите кнопку Data Validation (Проверка данных).

    Ограничение бюджета в Excel

  2. Выберите пункт Custom (Другой) из выпадающего списка Allow (Тип данных).
  3. Введите формулу, показанную ниже, в поле Formula (Формула) и нажмите ОК.

    =SUM($B$2:$B$8)<=100
    =СУММ($B$2:$B$8)<=100

    Ограничение бюджета в Excel

    Пояснение: Сумма чисел в ячейках диапазона B2:B8 не может превышать бюджета размером в $100. Мы применяем проверку данных в диапазоне B2:B8 (не в ячейке B10!), потому что именно туда вводятся суммируемые значения. Прежде чем открыть окно проверки данных, мы выделили диапазон В2:В8, поэтому Excel автоматически вставил формулу во все ячейки этого диапазона. Обратите внимание на то, что мы используем абсолютную ссылку на диапазон.

  4. Чтобы убедиться, выберите ячейку B3 и нажмите кнопку Data Validation (Проверка данных).

    Ограничение бюджета в Excel

    Как видно на рисунке, эта ячейка также содержит формулу.

  5. Введите значение 30 в ячейку B7.

Результат: Excel выдаёт сообщение об ошибке. Невозможно превысить бюджет с лимитом в $100.

Ограничение бюджета в Excel

Примечание: Перейдите на вкладку Error Alert (Сообщение об ошибке), чтобы самостоятельно прописать текст оповещения об ошибке.

15.06.2015 12:57
1373

Комментарии

Нет комментариев. Ваш будет первым!