Подсчёт ошибок в Excel

Этот пример покажет, как создать формулу массива, которая подсчитывает количество ошибок в диапазоне.

  1. Мы используем функции IF (ЕСЛИ) и ISERROR (ЕОШИБКА) для проверки ошибок:

    =IF(ISERROR(A1),1,"")
    =ЕСЛИ(ЕОШИБКА(A1);1;"")

    Подсчёт ошибок в Excel

    Пояснение: Функция IF (ЕСЛИ) возвращает 1, если обнаружена ошибка. Если нет – пустую строку.

  2. Чтобы подсчитать ошибки, добавим функцию COUNT (СЧЁТ) и заменим А1 на диапазон A1:C3:

    =COUNTIF(IF(ISERROR(A1:C3),1,""))
    =СЧЁТ(ЕСЛИ(ЕОШИБКА(A1:C3);1;""))

    Подсчёт ошибок в Excel

  3. Закончим нажатием Ctrl+Shift+Enter.

    Подсчёт ошибок в Excel

Примечание: Строка формул указывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

  1. Пояснение:

    • Диапазон (массив констант), созданный с помощью функции IF (ЕСЛИ), хранится в памяти Excel, а не в ячейках листа.
    • Массив констант выглядит следующим образом: {1;"";1;"";"";"";"";"";1}.
    • Этот массив констант используется в качестве аргумента для функции COUNT (СЧЁТ), давая результат 3.
  2. Для подсчета специфических ошибок используйте функцию COUNTIF (СЧЁТЕСЛИ). Например, чтобы подсчитать количество ячеек, содержащих ошибку #DIV/0! (#ДЕЛ/0!), используйте формулу:

    =COUNTIF(A3:C3,"#DIV/0!")
    =СЧЁТЕСЛИ(A3:C3;"#ДЕЛ/0!")

    Подсчёт ошибок в Excel

05.08.2015 08:50
1386

Комментарии

Нет комментариев. Ваш будет первым!