Подсчёт уникальных значений в Excel

Этот пример показывает, как создать формулу массива, которая подсчитает уникальные значения.

  1. Воспользуемся функцией COUNTIF (СЧЁТЕСЛИ). Для примера подсчитаем количество чисел 5 в диапазоне A1:A6, используя следующую формулу:

    =COUNTIF(A1:A6,5)
    =СЧЁТЕСЛИ(A1:A6;5)

    Подсчёт уникальных значений в Excel

  2. Чтобы подсчитать уникальные значения, добавим функцию SUM (СУММ), 1/, и заменим 5 на A1:A6.

    =SUM(1/COUNTIF(A1:A6,A1:A6))
    =СУММ(1/СЧЁТЕСЛИ(A1:A6;A1:A6))

    Подсчёт уникальных значений в Excel

  3. Закончим ввод формулы нажатием Ctrl+Shift+Enter.

    Подсчёт уникальных значений в Excel

Примечание: Строка формул указывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

Пояснение:

  • Диапазон (массив констант), созданный с помощью функции COUNTIF (СЧЁТЕСЛИ), хранится в памяти Excel, а не в ячейках листа.
  • Массив констант выглядит следующим образом: {3;1;1;1;3;3}, что обозначает: три числа 7, одно значение "sun", одно значение "moon", одно число 5, три числа 7, три числа 7.
  • Все это сводится к {1/3;1/1;1/1;1/1;1/3;1/3}.
  • Этот массив констант используется в качестве аргумента для функции SUM (СУММ), давая результат 4.
05.08.2015 08:54
4432

Комментарии

Нет комментариев. Ваш будет первым!