Подсчёт вхождений текста в Excel

Этот пример научит вас подсчитывать число вхождений текста в выбранном диапазоне.

  1. К примеру, можно сосчитать количество ячеек, содержащих текст "star" по следующей формуле:

    =COUNTIF(A1:A7,"star")
    =СЧЁТЕСЛИ(A1:A7;"star")

    Подсчет вхождений в Excel

  2. Для подсчёта количества ячеек, содержащих "star" + 1 символ, подойдёт вот эта формула:

    =COUNTIF(A1:A7,"star?")
    =СЧЁТЕСЛИ(A1:A7;"star?")

    Вопросительный знак (?) соответствует ровно одному символу.

    Подсчет вхождений в Excel

  3. Подсчитать количество ячеек, содержащих "star" + ряд символов (от нуля и более), можно по формуле ниже:

    =COUNTIF(A1:A7,"star*")
    =СЧЁТЕСЛИ(A1:A7;"star*")

    Звездочка (*) соответствует ряду символов (от нуля или больше).

    Подсчет вхождений в Excel

  4. Также можно сосчитать количество ячеек, которые в любом случае содержат "star", воспользовавшись этой формулой:

    =COUNTIF(A1:A7,"star*")
    =СЧЁТЕСЛИ(A1:A7;"*star*")

    Эта функция подсчитывает все ячейки, которые содержат "star", независимо от того, что находится до или после искомого текста.

    Подсчет вхождений в Excel

  5. Ещё вы можете подсчитать количество ячеек, содержащих любой текст, прописав эту формулу:

    =COUNTIF(A1:A7,"*")
    =СЧЁТЕСЛИ(A1:A7;"*")

    Подсчет вхождений в Excel

20.07.2015 11:08
1492

Комментарии

Нет комментариев. Ваш будет первым!