Вложенные функции ЕСЛИ в Excel

Функция IF (ЕСЛИ) может быть вложенной в случае, когда нужно проверить несколько условий одновременно. Значение FALSE (ЛОЖЬ) может измениться на другое, если функция продолжит проверку. Для примера посмотрите на формулу ниже:

=IF(A1=1,"Bad",IF(A1=2,"Good",IF(A1=3,"Exellent","No Valid Score")))
=ЕСЛИ(A1=1;"Bad";ЕСЛИ(A1=2;"Good";ЕСЛИ(A1=3;"Exellent";"No Valid Score")))

  1. Если значение в ячейке A1 равно 1, функция возвращает Bad.

    Вложенная функция ЕСЛИ в Excel

  2. Если значение в ячейке A1 равно 2, функция возвращает Good.

    Вложенная функция ЕСЛИ в Excel

  3. Если значение в ячейке A1 равно 3, функция возвращает Excellent.

    Вложенная функция ЕСЛИ в Excel

  4. Если ячейка A1 принимает другое значение, функция возвращает No Valid Score.

    Вложенная функция ЕСЛИ в Excel

Вот еще один пример:

=IF(A1<=10,350,IF(A1<=20,700,IF(A1<=30,1400,2000)))
=ЕСЛИ(A1<=10;350;ЕСЛИ(A1<=20;700;ЕСЛИ(A1<=30;1400;2000)))

  1. Если значение в ячейке A1 меньше или равно 10, функция возвращает 350.

    Вложенная функция ЕСЛИ в Excel

  2. Если значение в ячейке A1 больше, чем 10, но меньше или равно 20, функция возвращает 700.

    Вложенная функция ЕСЛИ в Excel

    Вложенная функция ЕСЛИ в Excel

  3. Если значение в ячейке A1 больше, чем 20, но меньше или равно 30, функция возвращает 1400.

    Вложенная функция ЕСЛИ в Excel

  4. Если значение в ячейке A1 больше, чем 30, функция возвращает 2000.

    Вложенная функция ЕСЛИ в Excel

Примечание: Возможно, в своей формуле вы захотите использовать "<" вместо "<=", чтобы немного изменить границы.

20.07.2015 16:16
5163

Комментарии

Нет комментариев. Ваш будет первым!